Eclipse

starting - running - debuggingCVS - under LINUX - Plug-ins - C/C++

Eclipse is a free professional java editor and to our experience, one of the best ever.
Download "Eclipse IDE version for Java Developers" or "Eclipse Classic" from the download section of website.

Warning: when using Eclipse, don't change things of your code outside Eclipse, like moving or renaming files, your eclipse project will get messed up (if problems: try F5 Refresh).

Understand the organization of Eclipse.

Tips for using Eclipse smartly.

Extensive tutorial for beginners.

Students: Install our default libraries.

Starting     (hier is ook nog documentatie te vinden in het Nederlands)

You must first choose a folder for your current Workspace. In it you create  projects (choose Java Project), which can consist of several source folders (src by default) and  packages.
        If the folder exists already, with java files, they are added automatically to the project.
Normally, the java perspective is selected automatically (perspective = a collection of windows, called views in Eclipse).
Add files:
If eclipse complains that workspace is in use, either you have already a version of eclipse running or a .lock file is left after a system crash in the .metadata folder of the workspace folder. Simply delete this file.

Running

For running a program: select the file with the main, click the right mouse button and select Run As, then Java Application.
An alternative is to click on the arrow next to the run button , then on the run button  and create a New configuration (java application or java applet, ...). Eclipse will find the main and adds it to the run configurations.

If running does not succeed (eg "cannot find main class"), there is still a compilation problem (eg. no disk space left). Check it under the Problems tab.

Change the current java version: Window => Preferences => Java => Installed JREs.
You find the current version next to JRE System Library  in your java project. It also gives the installed libraries. Doubleclick on it. The java path is typically C:\program files\java\jre***. That's where to put additional java libraries (our libraries).

Debug

Eclipse got a very powerfull debugger! Start it with the debug icon . Put or remove breakpoints by right clicking in the left margin of your code and choosing Toggle breakpoint.
Eclipse switches to the Debug Perspective containing a Variables view in which you will see the values of the variables. When selecting an object, it prints the object using the toString() method.
Use Resume  (F8) to let the program continue to the next breakpoint. Alternatively, choose step-by-step execution with Step Into  (F5),  Step Over  (F6) or Step Out  (F7).

CVS under Eclipse

CVS is a useful code management and sharing tool. It uses a centralized repository where your files are stored plus its history(!).
A repository consists of modules. In Eclipse a module will correspond to a project.

CVS configuratie

Choose menu item Window => Show View => Other => CVS =>  CVS Repositories.
In the CVS Repositories window choose the Add Repository icon and fill in the Location, your Authentication and choose extssh as Connection type for Sourceforge.
The first time, a key is generated for creating an authenticated connection, just click yes.
Doubleclick HEAD to view all modules of the repository en download them with the right mouse => Check Out.

CVS synchronisatie

Eenmaal CVS geconfigureerd is kan je je code synchroniseren via de rechtmuismenu => Team:

Under LINUX

Eclipse is also available for C++ and Linux
on our system use:  eclipse-3 -vmargs -Dosgi.locking=none
add as VM argument: -Djava.util.prefs.syncInterval=2000000  (to prevent error with java.util.pref.Preferences syncWorld)
our CVS repository: 10.0.4.209 and /home/cvsroot

Plug-ins

Het succes van Eclipse is ondermeer te danken aan zijn vele plugins, bijvoorbeeld te vinden op hun website.

GUIs maken met de Visual Editor

    De Visual Editor installeer je met de ingebouwde Install Manager (zie ook hier als je eclipse 3.4 of 3.5 hebt of hier voor oudere versies):
            Help => Install new software
       Klik Add Site...
            Add the VE 1.4 Update site
		http://download.eclipse.org/tools/ve/updates/1.4/
            Expand the VE site, select "Visual Editor", and hit "Install..."   (enkel Visual Editor selecteren. Ik kreeg problemen (met EMF) indien ik alles wou installeren.)

Gebruik:
          Kies Visual Class om een nieuwe GUI aan te maken (pijltje naast ). Kies een basiscomponent: Frame voor een Window, ...
          Een component toevoegen doe je via de Palette (tover je tevoorschijn door rechts op de - palette - aanduiding te klikken):
          Eigenschappen van de componenten kan je kiezen in de properties tab (in het onderste gedeelte), onder de Java Beans tab zie je de hierarchische structuur van alle componenten.
          Indien je file van je GUI niet als visueel component geladen wordt, doe je dit door in de Package Explorer in het menu van de linkermuisknop Open With -> Visual Editor te kiezen.
         
Opmerking: De code en de visuele component worden steeds gesynchronizeerd, als je een aanpast, volgt de ander, in beide richtingen. Maar soms geraakt VEP in de war. Het helpt om de file te sluiten en te heropenen. Meestal komt het dan wel goed. Let op, niet alle aanpassingen aan de code kan hij tonen in de grafische voorstelling. De tool werkt maar beperkt.

GUIs maken met de Google Windowbuilder Pro (een alternatief voor de Visual Editor)

  Instructieshttp://code.google.com/intl/nl-NL/javadevtools/download-wbpro.html

  Joris Borms, ervaringsdeskundige: "Dat is een tool voor Eclipse die vroeger commercieel door een bedrijf verkocht werd (Instantiations), maar nu dat bedrijf door Google is opgekocht hebben ze besloten de tool gratis te distribueren. Je kan hem gewoon downloaden via de Eclipse update manager () en in volgende versie van Eclipse zou hij misschien zelfs standaard in steken. Ik heb er al wat in zitten prutsen en het steekt wel goed in elkaar precies. Alleszins stabieler dan de Visual Editor, daar zaten precies wel wat bugs in die niet meer opgelost geraakten."

UML-diagrammen genereren met Omondo
Zo kan je je UML-diagrammen automatisch laten genereren. Je moet dit eens bekijken:

Omondo Studio  http://www.omondo.com/
"Deze tools zijn volgens mij de beste, en bovendien zijn ze geïntegreerd met Eclipse. Ik heb wel veel problemen gehad om ze te installeren. Dit is me trouwens geen tweede keer gelukt. Als je het probeert, neem dan ineens de Studio versie, want de Free werkt niet met gedeelde projecten (CVS).

Omdat dit dus bij mij niet zo goed lukte, is er nog de volgende tool: Fujaba Tool Suite. Dit is niet geïntegreerd met Eclipse (er is wel een FujabaForEclipse, maar die kan niet wat wij willen).
Met Fujaba werk je als volgt:
1) download http://wwwcs.upb.de/cs/fujaba/downloads/packages/Fujaba_4/FujabaToolSuite_Developer4_0_1.zip
2) Open de jarfile fujaba.jar  die in de gedownloade zip steekt
3) Kies in het menu Import/export voor "Import Java Directory"
4) Ga naar de directory waarin de files steken waarvan je een uml-diagram wil maken, bvb javasim/be/ac/vub/tw/graph/editor/composite   en klik op ok
5) Fujaba gaat nu je files bekijken
6) Daarna zie je aan de linkerkant twee mapjes: class diagram en activity diagram. Dubbelklik op class diagram en er verschijnt een nieuw bestand.
7) Klik daar met de rechtermuisknop op, en kies voor Edit Class Diagram. Daar kunt ge kiezen welke klassen weergegeven moeten worden en welke niet. Het zou immers kunnen dat er ook java-dingen in voorkomen, zoals JFrame of Vector ofzo. Die kan je dan van de linker- naar de rechterkolom klikken.
8) Als je nu op ok klikt, en eventueel links klikt op het diagram, dan verschijnt het in het rechtervenster.
Het is nog wel een beetje op elkaar geplakt (bij mij toch), maar dat kun je zelf uit elkaar schuiven.

9) nu: het printen of exporteren: je kan exporteren naar jpeg,png,tiff,svg en pdf.
PDF en PNG duurt eeuwen en lukt nooit.
Jpeg ging goed op kwaliteit 50, op 80 niet meer.
Tiff heb ik niet geprobeerd.
SVG gebeurt onmiddellijk. SVG staat voor Scalable Vector Graphics. Er bestaat een plugin voor Internet Explorer: Adobe SVG View
http://www.adobe.com/svg/

Daarmee kunt ge de gegenereerde SVG bekijken en afprinten. Je kan best je venster ongeveer even breed zetten als de UML, want anders print Adobe dat nogal verdund af. Verder print hij enkel hetgeen jezelf ziet, dus ge zult in verschillende keren moeten afprinten. Je kan door middel van Zoom Out en Zoom in het scherm verschuiven. (beetje proberen).

Het is inderdaad een heel gesukkel, maar het is zo ongeveer de enige manier die goed werkt bij mij.

Er zullen op internet misschien tools gevonden kunnen worden die SVG omzet naar een PDF of GIF ofzo, dus wie goed zoekt vind wel iets handiger.

Succes
Thomas "

Latex teksten editen met de Texlipse plugin

Write and manage your Latex texts in Eclipse.
First install Miktex http://www.miktex.org/
  Install plugin: Point your Eclipse Update site browser to: http://texlipse.sourceforge.net/
      Help => Install new software
For viewing your pdf-files:
    Window => Preferences => Texlipse => View Settings
       move acroread up
      Edit:  set Viewer Command to AcroRd32.exe in Program Files ...  (sometimes it is necessary to set %fullfile under Viewer Arguments)
use the same name for your pdf file as the latex file (project properties)

Andere plugins

   JDepend: Analysis of the dependencies within the code (review).
  Subclipse voor het geintegreerd gebruik van subversion in eclipse (CVS zit er standaard in)
          install the plugin from http://subclipse.tigris.org/update_1.6.x (Only select subclipse). (Check website for newer versions)
          Watch out: - change under Eclipse's preferences the SVN Interface from JavaHL to SVNKit. (Or install JavaHL)

C/C++

Eclipse is a language-independent IDE. Use the CDT plugin for programming in C or C++. Doc.

     Download CDT and extract the zip-file in the parent folder of your eclipse folder. Use the appropriate eclipse version.
     Install Cygwin with the gcc compiler (Cygwin gives you the linux tools on windows)
            Additionally to the default options, add gcc, make and gdb to the selection to be installed.
            Add the bin folder of your cygwin (eg c:\cygwin\bin) to the windows PATH : Control Panel -> System -> Advanced -> Environment Variables -> System Variables -> Edit -> Path  (the folder names should be separated with a semicolon)

Now you can make C or C++ projects. Take the Managed Make ones, they create the make file for you...